You are here

LabVIEW 에서 DLL 작성

본 어플리케이션 노트는 LabVIEW 7.1 (한글판) 이전 버전까지만 해당합니다. 이후 버전은 “LabVIEW 도움말”에서 “공유 라이브러리, 만들기(사용법)”을 참고하십시오. 

LabVIEW의 Application Builder를 사용하면 VIs에서 공유 라이브러리(DDL)를 생성할 수 있으므로 LabWindows/CVI, Microsoft Visual C++ 및 Microsoft Visual Basic과 같은 텍스트 기반의 프로그래밍 언어를 사용하여 공유 라이브러리의 VI를 호출할 수 있습니다.

 

참고: LabVIEW Professional Development System은 Application Builder를 포함합니다. LabVIEW Base Package 또는 Full Development System을 사용하는 경우, 아래의 관련 링크를 사용하여 Application Builder를 별도로 구입하실 수 있습니다.
아래 대화상자의 필드 설명을 포함하여 공유 라이브러리 생성에 대한 자세한 내용은Help»Contents and Index를 선택하면 이용 가능한 LabVIEW Help를 참조하십시오.

 

목차:

  • VI 생성
  • LabVIEW에서 DLL 생성
  • LabVIEW DLL 호출

 

VI 생성

다음 단계에 따라 화씨 온도를 섭씨 온도로 전환하는 VI를 생성하십시오. VI는 텍스트 기반 프로그래밍 언어에서 쉽게 호출할 수 있습니다.

1. 다음 방정식을 사용하여 변환을 수행하는 VI를 생성합니다.
Deg C = (Deg F - 32) / 1.8

블록다이어그램과 프런트패널은 다음과 같이 나타납니다.

 

2. 커넥터 팬(Connector Pane : 윈도우 우측 상단의 그림에서 오른쪽 마우스 클릭)의 터미널에 컨트롤과 인디케이터를 할당합니다. 이 단계는 DLL을 생성하는 데 필요합니다. 터미널에 컨트롤과 인디케이터 할당하기에 대한 자세한 내용은 Help»Contents and Index를 선택하여 LabVIEW Help를 참조하십시오.

3. DLL을 생성할 때 VI가 메모리에 있을 수 없으므로 VI를 저장하고 닫습니다.

 

LabVIEW에서 DLL 생성

다음 단계에 따라 작성한 VI에서 DLL을 생성합니다.
1. 새 VI를 열고 Tools»Build Application or Shared Library(DLL)를 선택합니다.
2. Build Target 필드의 Shared Library(DLL)를 선택하고 DLL과 대상 및 지원 디렉토리를 지정합니다.

 

3. Source Files 탭을 클릭하고 Add Exported VI 버튼을 클릭한 다음 주 VI를 더블 클릭합니다. 그러면 다음과 같은 대화상자가 나타납니다.
4. 입력 파라미터(DegF)를 선택하고 더하기(+) 버튼을 클릭하여 DLL에 입력을 추가합니다. 또한 파라미터를 값 또는 값에 대한 포인터로 전달할지를 선택합니다. 이 경우 Pass By Field에서 Value를 선택합니다. 함수 프로토타입은 대화상자의 하단에서 바뀝니다.
5. Deg C 출력과 같은 다른 파라미터에 대해 이전 단계를 반복합니다. 이 출력은 기본적으로 포인터로서 전달됩니다.
6. 또한 함수의 반환 값으로 출력 파라미터를 선택할 수 있습니다. 다음 함수는 void 대신 DegC 64 비트 부동 소수점 수를 반환합니다. 따라서 함수에서 출력을 생성할 때 두 가지 옵션을 사용할 수 있습니다. 출력 파라미터로 추가하거나 반환할 수 있습니다. 다음 함수는 두 가지를 모두 수행합니다.

 

Define VI Prototype 대화상자에서 OK 버튼을 클릭합니다
7. Build Application or Shared Library (DLL) 대화상자에서 Build 버튼을 클릭하여 DLL을 생성합니다. LabVIEW는 헤더 및 라이브러리 파일과 함께 대상 디렉토리에 DLL을 생성합니다. 이 예에서 대상 디렉토리는 c:\temp\app입니다.

 

 

관련 링크:

Windows용 LabVIEW Application Builder

Mac OS용 LabVIEW Application Builder

Linux용 LabVIEW Application Builder